summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/fonttools
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest3
-rw-r--r--dev-python/fonttools/fonttools-4.24.4-r1.ebuild48
-rw-r--r--dev-python/fonttools/metadata.xml1
3 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 9ed7b985895f..47ee67a5a8d3 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,5 +1,6 @@
DIST fonttools-4.23.1.tar.gz 2550938 BLAKE2B df592a9a9e54b4b542bb2e5dc0ea7d56f25cbe7b5cf38cb3e38e5f6feee1a8befbebab2b2c73ae814234a26440bcd3e6869335037c962d482694b4e35cd5dd78 SHA512 ef7faccfabdd66655195ad4d1d09599e302dcc393ff88cf005732930cec62df3c05e06795fafe7cd1ef89671faef2bf642f94e6ab33ebdacaa388c254a71792b
DIST fonttools-4.24.4.tar.gz 2556059 BLAKE2B c415ae5214b6df7171a5f8a7ea179b1a4adbc6646598d773f0d3d6a8cd777e8fd3c74c14f00e6c4735a73e712e3fd42ddfc96f3f101d34b122fb9c471d4d94a3 SHA512 aa4ee8f0a7f9cb6d8a84497e6f33f891491cd06cc477a785715f8fde8e5b33cf781ef8b848bfab8cf9a97fc15c018d493c6baf0fb8fd314b8a348c36ff627f41
EBUILD fonttools-4.23.1.ebuild 1275 BLAKE2B c141c4c40de9f3eec1679e8b574ec266962a6749c1a16fdf6fa8ebc7e8cb6cf705f7c0907a55793efa1f31d8f9bc65a9708a865ddd8897a5956c7161be354ace SHA512 4204c3df209a287f41da115fc6f04ae40938dfcc50721636c9273f69821c29e63ea9ebd33a2a7dfd0b97f067f519376f4f0707fbea10de8e87dce12527ebe5e2
+EBUILD fonttools-4.24.4-r1.ebuild 1303 BLAKE2B e27de8a4b573c7aac56b6b6e64ef2e68ddfd3e4bcd8ec7cdf10fed6d18261c2c1916a15d1fc40b85288a3b4513ee4abe687c2be796cd34db09aa68b88f06dedb SHA512 1dc4ae9e85b5dce901a56f82b9579c2995852833ce86d7186c013632f214781d1a44574249fa7d5fd477f0fabca745af33ace8e9b19592998854ed9eb2a89ead
EBUILD fonttools-4.24.4.ebuild 1283 BLAKE2B b992a7ff5e4b3e659959dcadf0a3efda6e899f0a2aa1cbf229d14ae7ec64d54bd089477aa65d4e0a7891b01bcee7491bd4d2dc1312cfa7b18d5f2746bd6694b5 SHA512 62d6b43bcf6cc7d154955a79efc9df2e3fbf6fb95d47415c6e3f61170bd61e839b9599450c58d14ab93210de09e798a3747d0aa6ab68096ccbb5cfe465daf832
-MISC metadata.xml 395 BLAKE2B f31a990237241b04b7e3222093c878d57d990ee97466160947d4c85a5798543a76c480b01a8f1da13057773b3b6b6dc270d039a4211d7d5cde8991bfa9b7632c SHA512 6c676733e48ceab4d6dcc56359c62d610728e06e7483648d410cbb0826c603521823a0f73b6d832b0f90b3e2f6254a92195e751867e16fbdef8335bbb0bec430
+MISC metadata.xml 371 BLAKE2B 68c245e8fa48ff65af06976274a7352964e39e13147683e266688f953d82d67e0548dacfe675bbd2e6807945c2e367bf08de4d18f75d53f44b28ecdcc8e7f188 SHA512 489bf8cc57a5bd577fa8949ae0ea9ec8be9a77bd6853e549c830f60ba6a152bc7dd25b2f3426974ea6448120113808ff627f9179e5e1e70105003057008aa86c
diff --git a/dev-python/fonttools/fonttools-4.24.4-r1.ebuild b/dev-python/fonttools/fonttools-4.24.4-r1.ebuild
new file mode 100644
index 000000000000..e40813acd252
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.24.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx epytest Tests fontTools
+}
diff --git a/dev-python/fonttools/metadata.xml b/dev-python/fonttools/metadata.xml
index 303f1de441d2..2cf256f7f2f0 100644
--- a/dev-python/fonttools/metadata.xml
+++ b/dev-python/fonttools/metadata.xml
@@ -5,7 +5,6 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
- <stabilize-allarches/>
<upstream>
<remote-id type="github">fonttools/fonttools</remote-id>
<remote-id type="pypi">fonttools</remote-id>