summaryrefslogtreecommitdiff
path: root/dev-python/fonttools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
commita87296ad796f00f3bba27339f6efe11b9a384e23 (patch)
tree1a47aa193935e1eb80c6ce1c7ececdcf9d44dfb3 /dev-python/fonttools
parent724cccb689f2076a398ede6845749926c86ea647 (diff)
gentoo auto-resync : 27:02:2023 - 22:02:09
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/files/fonttools-4.38.0-pypy3.patch34
-rw-r--r--dev-python/fonttools/fonttools-4.38.0-r1.ebuild70
3 files changed, 106 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 8179f27f0f3f..b9dae9f35860 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,3 +1,5 @@
+AUX fonttools-4.38.0-pypy3.patch 1293 BLAKE2B 46dc4127325ad45c014fb746b8883f1bae982b869b5615374ab9b40edc83f84c5914430fca6788d4a19b8899b569a0c4fee63e6567b9d40ff9b0d184019fe0f5 SHA512 8b0b8178fb633cd95ffde0d079e059ceaee592400fe4a1cc99d1b46aa994c37b5cc6200ea6adbef918dbf723caf57f0fddf8530a73d1e4acce9085e9d5eb4075
DIST fonttools-4.38.0.gh.tar.gz 3603281 BLAKE2B 8ec558c35cc10b32760eb199dce7c40934210db9ba8c9b0ad7a8cd2ca206260d2d73769bd1ff4cb597dd46cd50a42d733c967199120366e22abc5ee2b81e0919 SHA512 438694e7a4c19ee63ab504763793c0219d96fdc58095fe55a4f44726e96a3ec8ae63066aa47a341a059c7a2c9893b9bbbdfc8ab4d75c177cbd90986debc31431
+EBUILD fonttools-4.38.0-r1.ebuild 1625 BLAKE2B 96e00d45e4539562f0b7efa9f3a5a0e5c663a3a55d794e8418c308d849ac151007e336757e3a9586d5e31e3aca15dfe599b1af79f80be181a28d4b6a8ba291f3 SHA512 ca6cb51f3c6f924303ed5fa7db0cfe917c788e529e4453482ad40c53a14aa7546e1056e831b93aca8bf43fa9c6c8d20ef7e7a3cfb887081e205f309a46ea32dc
EBUILD fonttools-4.38.0.ebuild 1554 BLAKE2B f471c0c66b420bdb147bbaf8b33d3df00b4773c7b585503e44350f03c1dc6439c5572146f39869dce51d53148cc65218384a1fbd28855066c6e13bbaedb27782 SHA512 8e202db0ae5e85e34469f59b601628089cc296c244b2ed5ebdddc48b2df2c5a586e57b387fbf5c073b220c751b083058d7560c3516153bdf6765392a13cdca72
MISC metadata.xml 372 BLAKE2B 950ec78bf127250847c6513c22a5108b251afdb000d361068edf9d00d64a5baf6925ba4058bb889724febb28d92abc044c29af5936a48d8e8951b12314b64357 SHA512 03e76e28959bab83fe41c3ee4b55692ced9b1360e73e38a6e8f6e5c06fd1185dcbe0214aea2edff18d248abf252c1877d0d2c2b78b8e088e606c09c34e93e7ac
diff --git a/dev-python/fonttools/files/fonttools-4.38.0-pypy3.patch b/dev-python/fonttools/files/fonttools-4.38.0-pypy3.patch
new file mode 100644
index 000000000000..4a85cde3891e
--- /dev/null
+++ b/dev-python/fonttools/files/fonttools-4.38.0-pypy3.patch
@@ -0,0 +1,34 @@
+url: https://github.com/fonttools/fonttools/issues/2996
+
+commit ca9d98d94c3ba98db934f0d1e3a77134171f2262
+Author: Jérôme Carretero <cJ-gentoo@zougloub.eu>
+Date: Fri Feb 17 19:24:46 2023 -0500
+
+ Fixup pypy3 compatibility
+
+diff --git a/Lib/fontTools/misc/macCreatorType.py b/Lib/fontTools/misc/macCreatorType.py
+index 6b191054b..f680f238d 100644
+--- a/Lib/fontTools/misc/macCreatorType.py
++++ b/Lib/fontTools/misc/macCreatorType.py
+@@ -24,7 +24,7 @@ def getMacCreatorAndType(path):
+ """
+ if xattr is not None:
+ try:
+- finderInfo = xattr.getxattr(path, 'com.apple.FinderInfo')
++ finderInfo = xattr.getxattr(str(path), 'com.apple.FinderInfo')
+ except (KeyError, IOError):
+ pass
+ else:
+diff --git a/Lib/fontTools/subset/svg.py b/Lib/fontTools/subset/svg.py
+index 4ed2cbd20..4a8823928 100644
+--- a/Lib/fontTools/subset/svg.py
++++ b/Lib/fontTools/subset/svg.py
+@@ -77,7 +77,7 @@ def iter_referenced_ids(tree: etree.Element) -> Iterator[str]:
+
+ attrs = el.attrib
+ if "style" in attrs:
+- attrs = {**attrs, **parse_css_declarations(el.attrib["style"])}
++ attrs = {**dict(attrs), **dict(parse_css_declarations(el.attrib["style"]))}
+ for attr in ("fill", "clip-path"):
+ if attr in attrs:
+ value = attrs[attr]
diff --git a/dev-python/fonttools/fonttools-4.38.0-r1.ebuild b/dev-python/fonttools/fonttools-4.38.0-r1.ebuild
new file mode 100644
index 000000000000..d401fb8fb46d
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.38.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="
+ https://github.com/fonttools/fonttools/
+ https://pypi.org/project/fonttools/
+"
+SRC_URI="
+ https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/fonttools-4.38.0-pypy3.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}