summaryrefslogtreecommitdiff
path: root/dev-python/flatdict/flatdict-4.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 11:34:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 11:34:26 +0100
commitc83738e70baeab2df370c1c73b13bb8feb99eb11 (patch)
tree25031d5df1ae5d4c570107752277be06b970bcbf /dev-python/flatdict/flatdict-4.0.1.ebuild
parent3e1b17a1a1b2bac1314c0ea171fbd05bb098f02b (diff)
gentoo auto-resync : 09:04:2023 - 11:34:26
Diffstat (limited to 'dev-python/flatdict/flatdict-4.0.1.ebuild')
-rw-r--r--dev-python/flatdict/flatdict-4.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/flatdict/flatdict-4.0.1.ebuild b/dev-python/flatdict/flatdict-4.0.1.ebuild
new file mode 100644
index 000000000000..5a3a5555d40a
--- /dev/null
+++ b/dev-python/flatdict/flatdict-4.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for interacting with nested dicts"
+HOMEPAGE="
+ https://github.com/gmr/flatdict/
+ https://pypi.org/project/flatdict/
+"
+SRC_URI="
+ https://github.com/gmr/flatdict/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest