summaryrefslogtreecommitdiff
path: root/dev-python/flatbuffers/flatbuffers-23.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-04 07:37:02 +0000
commit5ae7efc9abae6bb8f8fac438298427769a91f5ad (patch)
treedc25abd0d9e2475f76b5060721ab492d2958a45f /dev-python/flatbuffers/flatbuffers-23.3.3.ebuild
parent2e6b794bf4361b8ae32bb6945e84696c2e1d94ba (diff)
gentoo auto-resync : 04:03:2023 - 07:37:01
Diffstat (limited to 'dev-python/flatbuffers/flatbuffers-23.3.3.ebuild')
-rw-r--r--dev-python/flatbuffers/flatbuffers-23.3.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/flatbuffers/flatbuffers-23.3.3.ebuild b/dev-python/flatbuffers/flatbuffers-23.3.3.ebuild
new file mode 100644
index 000000000000..5d38fe89b725
--- /dev/null
+++ b/dev-python/flatbuffers/flatbuffers-23.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="
+ https://github.com/google/flatbuffers/
+ https://pypi.org/project/flatbuffers/
+"
+SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ # zeroes means without benchmarks
+ "${EPYTHON}" py_test.py 0 0 0 false || die
+ "${EPYTHON}" py_flexbuffers_test.py -v || die
+}