summaryrefslogtreecommitdiff
path: root/dev-python/flatbuffers/flatbuffers-23.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
commitf29a41111b3a606f5d95049b1ba92daabbc68cc0 (patch)
tree310589df1ffb427b1a0595a329cfb2845335b778 /dev-python/flatbuffers/flatbuffers-23.1.4.ebuild
parent083bdfbef9bc532b72cf116591025916eebaf676 (diff)
gentoo auto-resync : 05:01:2023 - 12:08:57
Diffstat (limited to 'dev-python/flatbuffers/flatbuffers-23.1.4.ebuild')
-rw-r--r--dev-python/flatbuffers/flatbuffers-23.1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/flatbuffers/flatbuffers-23.1.4.ebuild b/dev-python/flatbuffers/flatbuffers-23.1.4.ebuild
new file mode 100644
index 000000000000..b912ff2765df
--- /dev/null
+++ b/dev-python/flatbuffers/flatbuffers-23.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="
+ https://github.com/google/flatbuffers/
+ https://pypi.org/project/flatbuffers/
+"
+SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ # zeroes means without benchmarks
+ "${EPYTHON}" py_test.py 0 0 0 false || die
+ "${EPYTHON}" py_flexbuffers_test.py -v || die
+}