summaryrefslogtreecommitdiff
path: root/dev-python/flatbuffers/flatbuffers-22.10.26.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-27 09:57:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-27 09:57:18 +0100
commitc70685892bc3f0b09aea1216ff278f6095f21281 (patch)
tree4f39843e13c4d3bfd7d02fcfde9adf66af6063b0 /dev-python/flatbuffers/flatbuffers-22.10.26.ebuild
parent6e8f2ebdce568f2c6c7870edbb9db5324a0e300f (diff)
gentoo auto-resync : 27:10:2022 - 09:57:18
Diffstat (limited to 'dev-python/flatbuffers/flatbuffers-22.10.26.ebuild')
-rw-r--r--dev-python/flatbuffers/flatbuffers-22.10.26.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/flatbuffers/flatbuffers-22.10.26.ebuild b/dev-python/flatbuffers/flatbuffers-22.10.26.ebuild
new file mode 100644
index 000000000000..7705da0c72e7
--- /dev/null
+++ b/dev-python/flatbuffers/flatbuffers-22.10.26.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="
+ https://github.com/google/flatbuffers/
+ https://pypi.org/project/flatbuffers/
+"
+SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+S=${WORKDIR}/${P}/python