summaryrefslogtreecommitdiff
path: root/dev-python/flask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-06 09:39:06 +0100
commit996d1cba721b044876526a7f3c1d2ef1fcc90bb4 (patch)
tree16fac72b3f131ad5671db34f88cd6426ff602706 /dev-python/flask
parent0cfdfb9b75c154c98f3963d4a002425218e29efc (diff)
gentoo auto-resync : 06:06:2023 - 09:39:05
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest2
-rw-r--r--dev-python/flask/flask-2.2.5.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index e7a69a3c5441..72ccd21de1af 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,5 +1,3 @@
-DIST Flask-2.2.5.tar.gz 697814 BLAKE2B 62d7bedf533f1e47c359c76e7a83e4edca15c3cac40f39d96897b150307ee4a151a9a17a71e369623635f2f0ab082d40cb2bb616e30c112c857c5a91896d07f5 SHA512 f399519716f95d0282da7dd2617e13841a7c12dbf8b440183839a0999b2fb9ede5fb5b6f4526e8539e432494e3aa29b7ccde992b0874c1ed0b2af2d030197457
DIST Flask-2.3.2.tar.gz 686251 BLAKE2B d81553b100e88ab79218422d6d39bb8b186f436c3729985504d1f54536b5e0f783509dcfbf0791890e7c03928131ddd4b8894db51f27e4075c50248ebd7846a2 SHA512 7917c3658a1dec77decad2dbc067a1ae602a66007573f1ff26527c214dede2c455ca5e6490159922fac967ceea99bd880cf929d05e21ed49b08abf501d96e8f8
-EBUILD flask-2.2.5.ebuild 1440 BLAKE2B 285d96058313bcbd179afb10da1ac9e8451e0b209262951d7d0ac6ea527bcf07fa0fb82f736ee3dfaf5e9afaef95124dbdd1ffe91bf3248640cdd28acd357b39 SHA512 1595e3c1b70e2aec21ab368d3fc4a3dd1e35912da09bfbc6efa44854eff9a2b199c7949d24246a846621016496d079b574a26e79c187c87efc4040ac0d064e4a
EBUILD flask-2.3.2.ebuild 1615 BLAKE2B 7bdffcdaf68ecfff3d7a00f21f910c3b239a728441535ab7342c907c695081b40784ef9b0f2de778c3dbe0d2be5828a46815d0bdc9c06321d237eba2d6458d07 SHA512 b93e5bf5e959d579da84a48c23cc6bc911c1a5cca1d2cf8b0fd7ba26a049bcd5ccd938ded093ce052abb5af72a78d02238a8712890ad2ca91ee2c91d943c72d9
MISC metadata.xml 386 BLAKE2B b449c54b966bc8943f7b7b12d6126867a89a2759eb749c08f7ad53a174e93ecad07f09b5e30c8562c63ab05df75a82e2f48f550ea8cf3a546f5afc2eef5a896d SHA512 123334db31948046e47f3cdbe0237cdec3dc2207485c8243d1e34e065436995423b6a89909563a6158741a8cc62a7fdad95923870a7114cf69e58ef715e7ec5c
diff --git a/dev-python/flask/flask-2.2.5.ebuild b/dev-python/flask/flask-2.2.5.ebuild
deleted file mode 100644
index 50981fdaf46e..000000000000
--- a/dev-python/flask/flask-2.2.5.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="
- https://palletsprojects.com/p/flask/
- https://github.com/pallets/flask/
- https://pypi.org/project/Flask/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- inherit pypi
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/click-8.0[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib-metadata-3.6.0[${PYTHON_USEDEP}]
- ' 3.8 3.9)
-"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- !!dev-python/shiboken2
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinx-issues \
- dev-python/sphinx-tabs \
- dev-python/sphinxcontrib-log-cabinet
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p no:httpbin
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}