summaryrefslogtreecommitdiff
path: root/dev-python/flask/flask-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/flask/flask-1.1.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/flask/flask-1.1.1.ebuild')
-rw-r--r--dev-python/flask/flask-1.1.1.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/dev-python/flask/flask-1.1.1.ebuild b/dev-python/flask/flask-1.1.1.ebuild
index 80cc931b35be..3cfa93664536 100644
--- a/dev-python/flask/flask-1.1.1.ebuild
+++ b/dev-python/flask/flask-1.1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
inherit distutils-r1
@@ -22,7 +22,8 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="doc examples test"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]
@@ -31,27 +32,22 @@ RDEPEND="dev-python/click[${PYTHON_USEDEP}]
>=dev-python/werkzeug-0.15[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
+PATCHES=(
+ # taken from upstream git, will be in next release
+ "${FILESDIR}/flask-1.1.1-py38.patch"
+)
-python_compile_all() {
- use doc && emake -C docs html
-}
+distutils_enable_sphinx docs
python_test() {
PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
- py.test -v || die "Testing failed with ${EPYTHON}"
+ pytest -vv -p no:httpbin || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
use examples && dodoc -r examples
- use doc && HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}