summaryrefslogtreecommitdiff
path: root/dev-python/flask/flask-0.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /dev-python/flask/flask-0.12.2.ebuild
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'dev-python/flask/flask-0.12.2.ebuild')
-rw-r--r--dev-python/flask/flask-0.12.2.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/dev-python/flask/flask-0.12.2.ebuild b/dev-python/flask/flask-0.12.2.ebuild
index 498dd328b2fe..a6175a6ac4c9 100644
--- a/dev-python/flask/flask-0.12.2.ebuild
+++ b/dev-python/flask/flask-0.12.2.ebuild
@@ -7,30 +7,33 @@ PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
inherit distutils-r1
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
HOMEPAGE="https://github.com/pallets/flask/"
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
-RDEPEND=">=dev-python/blinker-1[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/click-2[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1[${PYTHON_USEDEP}]
>=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/click-2[${PYTHON_USEDEP}]"
+ >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/${MY_P}"
-
python_prepare_all() {
# Prevent un-needed d'loading
sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die