summaryrefslogtreecommitdiff
path: root/dev-python/flask-wtf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/flask-wtf
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flask-wtf')
-rw-r--r--dev-python/flask-wtf/Manifest4
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.14.2-r1.ebuild60
-rw-r--r--dev-python/flask-wtf/flask-wtf-0.14.2.ebuild54
-rw-r--r--dev-python/flask-wtf/metadata.xml16
4 files changed, 0 insertions, 134 deletions
diff --git a/dev-python/flask-wtf/Manifest b/dev-python/flask-wtf/Manifest
deleted file mode 100644
index 3b4217a0f301..000000000000
--- a/dev-python/flask-wtf/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST Flask-WTF-0.14.2.tar.gz 254903 BLAKE2B dd6b650d97622dbb56cc0bdd3c036f14e562181720ede0c48652b8fcbc88d2d684f013f0468e723b8b0746f2c6f44ca18ffe0ea353594680b47bc1212664ce52 SHA512 9d4b4b24eb24827aeb524699e6720eab384c42901a102daddd9fdc6b8dbc8eebec8c9d31a1e9052c9af4d61bd08eef8ef9dc4cdc8d9b950ff5bdd0201db1dfde
-EBUILD flask-wtf-0.14.2-r1.ebuild 1362 BLAKE2B b5a5723a99950cfbc263776f5c5edc106755f5bc73a681176c8f83465911950de1ccf8f50b28bb30f0750bb3f7da4a30590860a638a96276925923a2e695290d SHA512 308f86f9d237a6fc0ba97b18baa9f9437ba5441660c022801e5b0c4cdc27dd026503b1c20862a3350a789de32836b38c46168d0b522e556d733a06ebdc305a58
-EBUILD flask-wtf-0.14.2.ebuild 1375 BLAKE2B cd7c15f2f84bcd4956aca938b5832243006d832aac5a02723c56655669c66ea3d20212a37c8fb92fbed08530f2fbf3bfa82be7c54c3d05edabc960a070e0eaa4 SHA512 e1c6afcdc1218114d96e0a4da16a93a028cf6f67f551496a78a0a346484bda5d1da9aa33fe78007e0a622afd376bb86f03147133343a99174fef2b91f379c44b
-MISC metadata.xml 628 BLAKE2B ff9c34258d4f106beb1089406a7be3b776e9b60f72fe2885d7141a88096250334bc26c43881853ca5019f3a0b24f306315ac36f303efa28e2921698d8d5484d9 SHA512 cc8c127cf6483396ba9a849683ecbc34527a9d51c8464b8ba523f015244a5a4efe1052691150f8888e4577dee538a1280afab28901be367f8856405bf380aea7
diff --git a/dev-python/flask-wtf/flask-wtf-0.14.2-r1.ebuild b/dev-python/flask-wtf/flask-wtf-0.14.2-r1.ebuild
deleted file mode 100644
index 2d85e170feaf..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.14.2-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms"
-HOMEPAGE="https://pythonhosted.org/Flask-WTF/ https://pypi.org/project/Flask-WTF/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )
- doc? (
- ${RDEPEND}
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
- # tries to access things over the network
- rm tests/test_recaptcha.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- nosetests || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/flask-wtf/flask-wtf-0.14.2.ebuild b/dev-python/flask-wtf/flask-wtf-0.14.2.ebuild
deleted file mode 100644
index 102f1593796b..000000000000
--- a/dev-python/flask-wtf/flask-wtf-0.14.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-WTF"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple integration of Flask and WTForms"
-HOMEPAGE="https://pythonhosted.org/Flask-WTF/ https://pypi.org/project/Flask-WTF/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/wtforms-1.0.5[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-testing[${PYTHON_USEDEP}]
- dev-python/flask-uploads[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- dev-python/flask-babel[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/werkzeug[${PYTHON_USEDEP}]' python2_7 )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # tries to access things over the network
- rm tests/test_recaptcha.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-wtf/metadata.xml b/dev-python/flask-wtf/metadata.xml
deleted file mode 100644
index 39cf0b536952..000000000000
--- a/dev-python/flask-wtf/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">Flask-WTF</remote-id>
- <remote-id type="github">lepture/flask-wtf</remote-id>
- <bugs-to>https://github.com/lepture/flask-wtf</bugs-to>
- </upstream>
- <longdescription lang="en">
- Simple integration of Flask and WTForms, including CSRF, file upload and Recaptcha integration.
- </longdescription>
-</pkgmetadata>