summaryrefslogtreecommitdiff
path: root/dev-python/flask-sphinx-themes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/flask-sphinx-themes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flask-sphinx-themes')
-rw-r--r--dev-python/flask-sphinx-themes/Manifest4
-rw-r--r--dev-python/flask-sphinx-themes/files/flask-sphinx-themes-1.0.1-python2-encoding-kw.patch12
-rw-r--r--dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild27
-rw-r--r--dev-python/flask-sphinx-themes/metadata.xml12
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/flask-sphinx-themes/Manifest b/dev-python/flask-sphinx-themes/Manifest
new file mode 100644
index 000000000000..957d59412eb5
--- /dev/null
+++ b/dev-python/flask-sphinx-themes/Manifest
@@ -0,0 +1,4 @@
+AUX flask-sphinx-themes-1.0.1-python2-encoding-kw.patch 256 BLAKE2B 2ed9a849832d3e5233494c053183b0f54fedc761efc27973fa84a0a9a19cd8182f60eda706f9e0f3f047e7d0808bf0f448f8a096da213f9f66bcb38fe8f10fb1 SHA512 c0d0421de3492f7cdf7c29790e7df4476095dcb7d3f310997eea74b3c2370d8e3ebb27e661024326e587a15d9f888096695624809f592e69b4e026695bef89e4
+DIST Flask-Sphinx-Themes-1.0.1.tar.gz 8150 BLAKE2B d228666424318552f3c865f64b0ad478a3794162c533ce7c4cb50414964c04d3a8ec84d64fdcd05f26bdfdb6e3ceeb9d96b9ee7dc7d632f07f99454f92e1231c SHA512 65ab8dcc75697fc61e6f6f78ec497ece99eba19c48e778f79e3883079cd0d5e42a2e0f1cf3d656dedf92423d1758caf6fd2279907dd87b50f3a79700f66c5e65
+EBUILD flask-sphinx-themes-1.0.1.ebuild 713 BLAKE2B 5080991a6367bbe92c7d0a0328543b3a1cd2cf41f7756cd687b218fdbc486392d9415b8414f046773c47587025a969dacfcd84eeeea9b226ff2668186fb17e63 SHA512 1ef0896d4fba6f61898ba7afae95f051723b93d25a6c1b7ecbd2f7c60eab9b136dcf4e7f536187e116833dd7bb0cf7dbe59e90e9d4eda172c96c32dabd8c5ed7
+MISC metadata.xml 401 BLAKE2B ab2d8a70343e2d3fd3759e515323e03730854a6a2fe2c9ef28c7993ccedeb3f3edb1499041506075e9a31db360d8c6816a90953796e516cba0e3426b44ba8886 SHA512 0e955337b9b299ad56b385c1773eee4f1d3c6b191a31d9e23053034489571d7c0da6dab3cfc4a40cf458743155661356d22c2524097f88ff46dfb52dc824abe0
diff --git a/dev-python/flask-sphinx-themes/files/flask-sphinx-themes-1.0.1-python2-encoding-kw.patch b/dev-python/flask-sphinx-themes/files/flask-sphinx-themes-1.0.1-python2-encoding-kw.patch
new file mode 100644
index 000000000000..5f4f5d4d3bbf
--- /dev/null
+++ b/dev-python/flask-sphinx-themes/files/flask-sphinx-themes-1.0.1-python2-encoding-kw.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index d14f27b..40bffcc 100755
+--- a/setup.py
++++ b/setup.py
+@@ -1,6 +1,7 @@
+ #!/usr/bin/env python
+ import os
+ import re
++from io import open # for python 2 compat (missing 'encoding' kw)
+
+ from setuptools import setup
+
diff --git a/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild b/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild
new file mode 100644
index 000000000000..a4ace992473f
--- /dev/null
+++ b/dev-python/flask-sphinx-themes/flask-sphinx-themes-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Sphinx-Themes"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sphinx Themes for Flask related projects and Flask itself"
+HOMEPAGE="https://github.com/pallets/flask-sphinx-themes https://pypi.org/project/Flask-Sphinx-Themes/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-python2-encoding-kw.patch" )
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/flask-sphinx-themes/metadata.xml b/dev-python/flask-sphinx-themes/metadata.xml
new file mode 100644
index 000000000000..e6c5f932fd7a
--- /dev/null
+++ b/dev-python/flask-sphinx-themes/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Flask-Sphinx-Themes</remote-id>
+ <remote-id type="github">pallets/flask-sphinx-themes</remote-id>
+ </upstream>
+</pkgmetadata>