summaryrefslogtreecommitdiff
path: root/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/flask-socketio/flask-socketio-2.9.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/flask-socketio/flask-socketio-2.9.2.ebuild')
-rw-r--r--dev-python/flask-socketio/flask-socketio-2.9.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild b/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild
new file mode 100644
index 000000000000..60880a0c55de
--- /dev/null
+++ b/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Flask-SocketIO"
+DESCRIPTION="Socket.IO integration for Flask applications."
+HOMEPAGE="https://flask-socketio.readthedocs.org/ https://github.com/miguelgrinberg/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ >=dev-python/python-socketio-1.5.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ PYTHONPATH="${PWD}" python ./test_socketio.py || die
+}