summaryrefslogtreecommitdiff
path: root/dev-python/flask-restful
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/flask-restful
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flask-restful')
-rw-r--r--dev-python/flask-restful/Manifest5
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild50
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.6.ebuild50
-rw-r--r--dev-python/flask-restful/metadata.xml14
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/flask-restful/Manifest b/dev-python/flask-restful/Manifest
new file mode 100644
index 000000000000..88298740160a
--- /dev/null
+++ b/dev-python/flask-restful/Manifest
@@ -0,0 +1,5 @@
+DIST flask-restful-0.3.5.tar.gz 113214 BLAKE2B 0acf4d0449c55861b801a990bc3220d98e47ebeacb3c5b6452774992ae19ada97e31922e440a8a533bb1be68d4476e2654a8ca224b2369fd7733cc4c0da465c4 SHA512 a541e6739644b4db6ae97cf529bfc43f3136c97fc19a8538277d1f9be033b7c6dc3e39e1c4b2f313e099efbe750dbdc85c67b527224df557567ecac668e5969a
+DIST flask-restful-0.3.6.tar.gz 114512 BLAKE2B f03f7ed0fd521a265b8a2293d1526273650a38f65b28933b4d90d74f7365e04650efc89a743a49ab7c9fdd59d238958bb7bc03936f44af8728a4c435d2df23be SHA512 c5136302111e6c8953e038d31b42b029744111bb916dea7ec8bd5fac2de5e17a86d30a7d04a7335cdc5da25ee13f35ad9a6d284166e11cca0c6fec96d23fd977
+EBUILD flask-restful-0.3.5-r1.ebuild 1286 BLAKE2B d2ceb6bf29535323a8285d6fdfa228316f8c7cc03ca0bac4b6b0387ee7a4db8210e292792252066ab83b1667704a8c1af748f826fb4f2c5c776f4ca7a0340477 SHA512 78e52bb5a245c267e8b46e024f33c53f6bdb2c9cb3b05a3b46cdf1212f461816dfdbaa28651a37ada59abe99da86fa3ce7012deb88960b982820cfc69b54714f
+EBUILD flask-restful-0.3.6.ebuild 1288 BLAKE2B c485f495ba833d964c9ce3f7aff33d2ec145f1af62069d5ef476f37b783776170723fd96f041c4adf26fef738a9e89725ee4c5729eee47ad7d042f4d21aba0dc SHA512 f56cc8becd68cf46b1fc31504757c716cd6ecbca5118c8cd801c5ea8fa838b525f5b3218c9808b6554ea12b128c7d6ab9d7188685f89e5dbda25a4e956831e21
+MISC metadata.xml 400 BLAKE2B 73ff908518d52fcfb2aaf73571c5c1a36cf0cc749b0d1f5e2c28780323b096aed34644c8bf373e241112892e08dc184d0310bcce52aa583ad6301473cd7a4248 SHA512 be62c37c4d0fd8a051cc14fb2a9dec6885a1e83420bbe95282a0fdc7803d700372b345d83c3d648037c45080246d71b91086b3e4841d9e41fb3003d7c114e0c0
diff --git a/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild b/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..d7899765610d
--- /dev/null
+++ b/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple framework for creating REST APIs"
+HOMEPAGE="https://flask-restful.readthedocs.io/en/latest/ https://github.com/twilio/flask-restful/"
+SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples paging test"
+
+RDEPEND="
+ >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_compile_all() {
+ cd docs || die
+ emake man $(usex doc html "")
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
+
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-restful/flask-restful-0.3.6.ebuild b/dev-python/flask-restful/flask-restful-0.3.6.ebuild
new file mode 100644
index 000000000000..b4be50acfe91
--- /dev/null
+++ b/dev-python/flask-restful/flask-restful-0.3.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple framework for creating REST APIs"
+HOMEPAGE="https://flask-restful.readthedocs.io/en/latest/ https://github.com/twilio/flask-restful/"
+SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples paging test"
+
+RDEPEND="
+ >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_compile_all() {
+ cd docs || die
+ emake man $(usex doc html "")
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && dodoc -r examples
+ local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
+
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-restful/metadata.xml b/dev-python/flask-restful/metadata.xml
new file mode 100644
index 000000000000..7e42a30ff5f6
--- /dev/null
+++ b/dev-python/flask-restful/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">twilio/flask-restful</remote-id>
+ </upstream>
+ <use>
+ <flag name="paging">Enable resource paging support</flag>
+ </use>
+</pkgmetadata>