summaryrefslogtreecommitdiff
path: root/dev-python/flask-restful/flask-restful-0.3.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/flask-restful/flask-restful-0.3.9.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/flask-restful/flask-restful-0.3.9.ebuild')
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.9.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/flask-restful/flask-restful-0.3.9.ebuild b/dev-python/flask-restful/flask-restful-0.3.9.ebuild
new file mode 100644
index 000000000000..858cb0ca86fc
--- /dev/null
+++ b/dev-python/flask-restful/flask-restful-0.3.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple framework for creating REST APIs"
+HOMEPAGE="
+ https://flask-restful.readthedocs.io/en/latest/
+ https://github.com/flask-restful/flask-restful/"
+SRC_URI="
+ https://github.com/flask-restful/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests nose
+
+python_install_all() {
+ use examples && dodoc -r examples
+ local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
+
+ distutils-r1_python_install_all
+}