summaryrefslogtreecommitdiff
path: root/dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild')
-rw-r--r--dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild b/dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..2e383cb425ed
--- /dev/null
+++ b/dev-python/flask-principal/flask-principal-0.4.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Identity management for flask"
+HOMEPAGE="https://pythonhosted.org/Flask-Principal/ https://pypi.org/project/Flask-Principal/"
+SRC_URI="
+ https://github.com/mattupstate/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+# pypi tarball is missing tests
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest