summaryrefslogtreecommitdiff
path: root/dev-python/flask-paginate/flask-paginate-2024.4.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-12 06:33:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-12 06:33:48 +0100
commited7b29dac0f97dbcf5472b7556b83731a6b6b0d4 (patch)
treef33c5735088b95071719669ecfc18f0aef491ee9 /dev-python/flask-paginate/flask-paginate-2024.4.12.ebuild
parent3a6d209caa07e3be8e8423251b70c8bbeeedb17f (diff)
gentoo auto-resync : 12:04:2024 - 06:33:48
Diffstat (limited to 'dev-python/flask-paginate/flask-paginate-2024.4.12.ebuild')
-rw-r--r--dev-python/flask-paginate/flask-paginate-2024.4.12.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/flask-paginate-2024.4.12.ebuild b/dev-python/flask-paginate/flask-paginate-2024.4.12.ebuild
new file mode 100644
index 000000000000..e76b6ec74b90
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2024.4.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="
+ https://flask-paginate.readthedocs.io/
+ https://github.com/lixxu/flask-paginate/
+ https://pypi.org/project/flask-paginate/
+"
+SRC_URI="
+ https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}