summaryrefslogtreecommitdiff
path: root/dev-python/flask-mail/flask-mail-0.9.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/flask-mail/flask-mail-0.9.1-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/flask-mail/flask-mail-0.9.1-r1.ebuild')
-rw-r--r--dev-python/flask-mail/flask-mail-0.9.1-r1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/flask-mail/flask-mail-0.9.1-r1.ebuild b/dev-python/flask-mail/flask-mail-0.9.1-r1.ebuild
deleted file mode 100644
index bb13fb6b93d2..000000000000
--- a/dev-python/flask-mail/flask-mail-0.9.1-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Mail"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flask extension for sending email"
-HOMEPAGE="https://pythonhosted.org/Flask-Mail/ https://pypi.org/project/Flask-Mail/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/speaklater[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy) )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}