summaryrefslogtreecommitdiff
path: root/dev-python/flask-cors/flask-cors-4.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-27 07:34:25 +0100
commit61faa1ea0e8302df305bc281038fc00dc7eb1dd4 (patch)
tree80638756ce07f0db3bcdc33653970fa5452df743 /dev-python/flask-cors/flask-cors-4.0.0.ebuild
parent00757bf15f0eb42661625ed16888d00af9a79561 (diff)
gentoo auto-resync : 27:06:2023 - 07:34:25
Diffstat (limited to 'dev-python/flask-cors/flask-cors-4.0.0.ebuild')
-rw-r--r--dev-python/flask-cors/flask-cors-4.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/flask-cors/flask-cors-4.0.0.ebuild b/dev-python/flask-cors/flask-cors-4.0.0.ebuild
new file mode 100644
index 000000000000..59970129051b
--- /dev/null
+++ b/dev-python/flask-cors/flask-cors-4.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/corydolphin/flask-cors.git"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/corydolphin/flask-cors/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="A Flask extension for Cross Origin Resource Sharing (CORS)"
+HOMEPAGE="
+ https://github.com/corydolphin/flask-cors/
+ https://pypi.org/project/Flask-Cors/
+"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinxcontrib-httpdomain