summaryrefslogtreecommitdiff
path: root/dev-python/flaky
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/flaky
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest6
-rw-r--r--dev-python/flaky/flaky-3.1.1.ebuild45
-rw-r--r--dev-python/flaky/flaky-3.4.0.ebuild45
-rw-r--r--dev-python/flaky/metadata.xml12
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
new file mode 100644
index 000000000000..7f057e1e59f0
--- /dev/null
+++ b/dev-python/flaky/Manifest
@@ -0,0 +1,6 @@
+DIST flaky-3.1.1.tar.gz 29136 SHA256 d50eb4034d5fc1bbe043f2c9a364024f436ebdcadc03e89f091a332407b7cf7e SHA512 039ad115a52b8b3a31bba045874e1860f1e04ea9cf878316226fb22af3c715b3893570c2f7380cf8467107f1a83a4ff69d0e9135daeb2dbea4b8f873a192815c WHIRLPOOL 6fb841fe6aaf575a776ac1ebba262e1272fa194c517cdc1e8db125bdc339d67e23dbd7f8f3f3469741e50863bf564c93eb921e4e621e8f54ec815cdde9148712
+DIST flaky-3.4.0.tar.gz 29197 SHA256 4ad7880aef8c35a34ddb394d4fa33047765bca1e3d67d182bf6eba9c8eabf3a2 SHA512 14fda6312e4eb8260a8190204622a7dd274d0c946dda07ec8aa65e8c341f7f4a701c704c807f50eacf77589231b37c3bb06eec18d60a718f24e9b0182f7e8cb5 WHIRLPOOL b7e5501301bfa47398ab134625d482d3f3f0e38401df932fc234181204f7144fe34d0ef580a94ff6387e44dcef9d43cc82fc3887b059cd8f08fdc5523207b7e3
+EBUILD flaky-3.1.1.ebuild 1392 SHA256 3698ca10de1af11a5ba116325a02dd70c5238e251982d87d59d40333284a0085 SHA512 1ab7b7ea367bfe7ed15698cbe97ceb18c15b88fdcb097e28c3bcd770ec8b57564f36ab29e10eecf253983d532fffa06147edd52e438920fd09399a3516f83cac WHIRLPOOL d43a6ad93fabc15d887e6b09a8dc7593e7fea5f3c2258f3c19d2ab2bba2242fd968aa54a967cb8d5d18a3f33a62a84e8b1cf87af3d6a3aa6b39585c4898c3d58
+EBUILD flaky-3.4.0.ebuild 1401 SHA256 2f12102f3f0a66bcfd0d021695330e91969341ce7d000e350e6667b96144ac8a SHA512 4f973efe6f73fe8f19f857419fedc2bd5fe5d39ac8b62f52cea0dcfaff9cfdad861c2aaa6dda31f3b699df1572d3a611082d0e8603c8ec52729f9d863098005f WHIRLPOOL 8d0ef7cf8968b3a70c758648a55a96a786618a9435246955310405688a3c6d5dfa806cbc046e448b370366a653d8b870eeebc28d3fea3af5aa309cfa565b2e2e
+MISC ChangeLog 3280 SHA256 d4c6bfc1fb9ae5954daa25539745650f55f262880b1ce3968ffd1ee5514884bd SHA512 082a89da50b0263ecf784bea816849380f5be8e2b601164e9b5cd4795fb333c6eb863bc9c0dda4b107b338590ad9f3326bf74e01ae05a13d344649fb1b63acf6 WHIRLPOOL 669c67f250533df7ace43a2014e105065b0d7a2acd5a84ed5502e720293c2aebf2624f8664b46668890a9a30162e60cf8160b22cdbef8dd7bb8d90a248b657f4
+MISC metadata.xml 369 SHA256 0cacaa478bb88bcc9fcc72fffa77813fef4e26f213fd8926a48fe0df45f65518 SHA512 da1597d14b2e3f9bc56e48064718a2a52bc1615d982d679d8c971f1fb1b9c25169d5412f99542f808fa42f958e1bb589e7615a13077a7d1b0574acbec1d4b1dd WHIRLPOOL d1e423e0c187c075d5cb71f38cb1e82af590f1284bc0e840de238352fb74363a4edd71efdc7e287ba13d1d5917af279fc82b8a6809163497ae6a2d1d749c2929
diff --git a/dev-python/flaky/flaky-3.1.1.ebuild b/dev-python/flaky/flaky-3.1.1.ebuild
new file mode 100644
index 000000000000..28da53e5255d
--- /dev/null
+++ b/dev-python/flaky/flaky-3.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.python.org/pypi/flaky https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+python_prepare_all() {
+ cat >> test/__init__.py <<- EOF
+ # coding: utf-8
+
+ from __future__ import unicode_literals
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ py.test -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ py.test -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ py.test --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}
diff --git a/dev-python/flaky/flaky-3.4.0.ebuild b/dev-python/flaky/flaky-3.4.0.ebuild
new file mode 100644
index 000000000000..9f67738122dc
--- /dev/null
+++ b/dev-python/flaky/flaky-3.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.python.org/pypi/flaky https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+python_prepare_all() {
+ cat >> test/__init__.py <<- EOF
+ # coding: utf-8
+
+ from __future__ import unicode_literals
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ py.test -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ py.test -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ py.test --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}
diff --git a/dev-python/flaky/metadata.xml b/dev-python/flaky/metadata.xml
new file mode 100644
index 000000000000..8487b6711c9e
--- /dev/null
+++ b/dev-python/flaky/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">box/flaky</remote-id>
+ <remote-id type="pypi">flaky</remote-id>
+ </upstream>
+</pkgmetadata>