summaryrefslogtreecommitdiff
path: root/dev-python/flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
commit3b4199328e240d392ef1f03900219cb88bdafcff (patch)
tree06007a008d485a5e0a169f2807b68f456e9df1b3 /dev-python/flake8
parentaca0af8133e724b7edf0b5c6efe12c39077a3dc9 (diff)
gentoo auto-resync : 30:07:2023 - 22:42:58
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest2
-rw-r--r--dev-python/flake8/flake8-6.1.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 7d4b15ed86cd..ea6d779e2131 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,3 +1,5 @@
DIST flake8-6.0.0.gh.tar.gz 139138 BLAKE2B 87590594a95f48a9e532ca545d4ae17a098cba81a7708066d63180b27e1cd0e0b648a2362d16b3818ef1b91cbe9ecf51810d45136fb42f188fc09083e9b31921 SHA512 27de4632332ee72bb5deedfcb7ea59e31a3e7fbfd6c165adf019b06cccaba51b776f4310219d8b27cf4894ed2597330fe9c0e381187353d4dc239f102eedd26a
+DIST flake8-6.1.0.gh.tar.gz 139267 BLAKE2B 69210f4ebe5dd4b56425fca9289349820cc5dcee515f75cb855b095dc1a0a6ba380448f14fca19423940d853383576ddc665c5a7bd27f8aa96940ac410d8742b SHA512 a44d245b023acbb89e64071f6cb76f5543e538472a8815fa329a3b3671133cc6f96f246d83877a2a9ac91c32ecdf65858f8edf996efba77906af74b1632b74c8
EBUILD flake8-6.0.0.ebuild 1182 BLAKE2B a53b807da6ca89b1c292b39d655a8ae73951a98102126b9268dd9d4164ecd4148bbb3f9cd0202dea264ca2d4b8df0db896c314ce2219828ba0421c8e25e86427 SHA512 c6cb4689ee6fd1fa28aebe0894d4343360cf168692d27a8a7976945782f713047cfa3c04cccf8dc8a46ee873d04d8980a7fa7547dd5c1976d49ad4c77df4d9d6
+EBUILD flake8-6.1.0.ebuild 1631 BLAKE2B 525c1305ccc6421b6ef19327a37a5bced8a15b56e13620eb3cb73c86804042d7a6f435c11078d874d6cbcdeb609efd903aeec2f22c6901369f441b21635d7301 SHA512 ec819a329766c97c348874bf3eabc85878946ea0c713baa308038b39c72c0ab8fd700222d6b541b2b5f3f08dd622ba7f7e6d0d0eb99e86af278c6eebf8dfbe7d
MISC metadata.xml 399 BLAKE2B 01ae165c898af67195582e1aaf867b9f9fc937e56b87f09a812d21c9d1175131c25561524ba76857c1630a117a21bc43eeef907c2a34ab9e9b38866dc2f9430e SHA512 8f149a017f4fef8f8fe0fef037e589694e0c3b3689990f97f38ed23fb9b5c5170985fc1fd7814ef70b8200db66cb9367dcfc9bf6453f8742092335a1c3c8fae6
diff --git a/dev-python/flake8/flake8-6.1.0.ebuild b/dev-python/flake8/flake8-6.1.0.ebuild
new file mode 100644
index 000000000000..bba7b6815ba8
--- /dev/null
+++ b/dev-python/flake8/flake8-6.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="
+ https://github.com/PyCQA/flake8/
+ https://pypi.org/project/flake8/
+"
+SRC_URI="
+ https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ <dev-python/pyflakes-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-3.1.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
+"
+PDEPEND="
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-prompt \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails if additional flake8 plugins are installed
+ tests/integration/test_plugins.py::test_local_plugin_can_add_option
+ )
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ EPYTEST_DESELECT+=(
+ # problem with pypy3.10 in dev-python/pyflakes
+ # https://github.com/PyCQA/pyflakes/issues/779
+ tests/integration/test_main.py::test_malformed_per_file_ignores_error
+ tests/integration/test_main.py::test_tokenization_error_but_not_syntax_error
+ tests/integration/test_main.py::test_tokenization_error_is_a_syntax_error
+ )
+ fi
+
+ epytest
+}