summaryrefslogtreecommitdiff
path: root/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-29 21:37:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-29 21:37:46 +0000
commit6769d991d1a040381ab263b2eef043e6f50190a6 (patch)
tree94f6b868964e05c2497cdcd5ee402c03323a3e6a /dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
parent67c78fc4ac5b7eada5a0196fa051b16628dac90c (diff)
gentoo auto-resync : 29:10:2023 - 21:37:46
Diffstat (limited to 'dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild')
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
index a9585c884520..3157aedf6cf2 100644
--- a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
@@ -5,18 +5,28 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1 pypi
DESCRIPTION="Polyfill package for Flake8 plugins"
-HOMEPAGE="https://gitlab.com/pycqa/flake8-polyfill"
+HOMEPAGE="
+ https://gitlab.com/pycqa/flake8-polyfill/
+ https://pypi.org/project/flake8-polyfill/
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/flake8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest