summaryrefslogtreecommitdiff
path: root/dev-python/fixtures/fixtures-4.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 21:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 21:10:11 +0100
commita20b8556104c163a81183ff983af8123e40f16c5 (patch)
treefc59d7e55cf6c354a7a395587dcfbed577557a84 /dev-python/fixtures/fixtures-4.1.0.ebuild
parentf3a881e4cb31d574a107320b2f04e2d1f0ddf551 (diff)
gentoo auto-resync : 26:05:2023 - 21:10:11
Diffstat (limited to 'dev-python/fixtures/fixtures-4.1.0.ebuild')
-rw-r--r--dev-python/fixtures/fixtures-4.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/fixtures/fixtures-4.1.0.ebuild b/dev-python/fixtures/fixtures-4.1.0.ebuild
new file mode 100644
index 000000000000..cf139f9da0ad
--- /dev/null
+++ b/dev-python/fixtures/fixtures-4.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pbr
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="
+ https://github.com/testing-cabal/fixtures/
+ https://pypi.org/project/fixtures/
+"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pbr-5.7.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest