summaryrefslogtreecommitdiff
path: root/dev-python/fixtures/fixtures-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/fixtures/fixtures-3.0.0.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/fixtures/fixtures-3.0.0.ebuild')
-rw-r--r--dev-python/fixtures/fixtures-3.0.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/fixtures/fixtures-3.0.0.ebuild b/dev-python/fixtures/fixtures-3.0.0.ebuild
index d659f853923e..0f6eb5d60dcc 100644
--- a/dev-python/fixtures/fixtures-3.0.0.ebuild
+++ b/dev-python/fixtures/fixtures-3.0.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
inherit distutils-r1
@@ -25,7 +25,14 @@ RDEPEND="
>=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-#DISTUTILS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # broken on py3.9
+ # https://github.com/testing-cabal/fixtures/issues/44
+ sed -i -e 's:test_patch_classmethod_with:_&:' \
+ fixtures/tests/_fixtures/test_monkeypatch.py || die
+ distutils-r1_src_prepare
+}
python_test() {
emake check