summaryrefslogtreecommitdiff
path: root/dev-python/fire/fire-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-python/fire/fire-0.3.1.ebuild
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-python/fire/fire-0.3.1.ebuild')
-rw-r--r--dev-python/fire/fire-0.3.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/fire/fire-0.3.1.ebuild b/dev-python/fire/fire-0.3.1.ebuild
new file mode 100644
index 000000000000..5c4b134e8195
--- /dev/null
+++ b/dev-python/fire/fire-0.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="library for automatically generating command line interfaces"
+HOMEPAGE="https://github.com/google/python-fire"
+SRC_URI="https://github.com/google/python-fire/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]"
+BDEPEND=""
+
+S="${WORKDIR}"/python-${P}