summaryrefslogtreecommitdiff
path: root/dev-python/findimports
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 17:45:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 17:45:32 +0000
commit5939313f229e6fcf374fb7e9ee4f8675b05ab293 (patch)
tree0a8181cbc5d052ab4d26a8e1d2dc52f126063fc6 /dev-python/findimports
parent7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (diff)
gentoo auto-resync : 02:02:2024 - 17:45:32
Diffstat (limited to 'dev-python/findimports')
-rw-r--r--dev-python/findimports/Manifest2
-rw-r--r--dev-python/findimports/findimports-2.4.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/findimports/Manifest b/dev-python/findimports/Manifest
index 4fb668f69a6d..d61371931c1f 100644
--- a/dev-python/findimports/Manifest
+++ b/dev-python/findimports/Manifest
@@ -1,3 +1,5 @@
DIST findimports-2.3.0.gh.tar.gz 36667 BLAKE2B 3f0981a9819940d2fc5a1b1147b06552b5d98d90594ce94e3c02f1d69904dc65087603ae3375e5321386ae7d00eb82d4ed60d865829f56f6b4e8dbd7540c505c SHA512 f0023995bd5c79e33722a0af7f246e9a5a143fb7f5294b7e1e97b3eb82331f69f605d41551c09af53424d6bf8e41bd5817cc9e206a30d0fc0f1cc0131944e37c
+DIST findimports-2.4.0.gh.tar.gz 26597 BLAKE2B 8dc176a551a07f38996ddbcf0df865ad7c7c1c7f86036be0939578a932155f30bdff17d2880063edd49ae1d169ebfb5bbade771a626859ad8306d54df743ee79 SHA512 90dfc39a5f73ea86a9d5c3ebec0f220f2f428f5768edc9688c47079f555b44abb80b4945b38550032289a3bff659f3857019a50882b1b2f2e83570f3e36530be
EBUILD findimports-2.3.0.ebuild 544 BLAKE2B b58a8696443a51a6c5695aa072f8513bb3ec06764cf83b48b6ef231c065a1809795d6273712e21335992c12643b975750c81331fbd4c4acb8baf4679ab664234 SHA512 6d62378b7a930adf5d961cb30bff1d4d8d02908d5b422ffe9d0fb5cb1a053df2edf83f0b7251002717fefd8a81eeb4f6eb184eec450885de9cfc1f69b739d089
+EBUILD findimports-2.4.0.ebuild 544 BLAKE2B 2e3e4af606f1cc092d291b4c8f658a2eb07b42434017ea902aa53f8f321016351bb28b92de1690a13892646bc14fbdff22cf1b775e19f3984d54d0ff6f48da1d SHA512 c7d9f211234cda77bb899754e378fe1fb7a044111a947952f92ab65265ab4ca25d705bedefbc1ce398d082b83e73590f54ecda3a36b6f3bb9b994327c4a0baa7
MISC metadata.xml 381 BLAKE2B 75877d1e3859d37449ecefd9190904ed70c47b7c0d2ca6d751261edc8727dc512c7a8ea3fa3de72cbc15f23587e41a24e8b71b068afcfb7377b0205a409b5433 SHA512 eb41ce9af56f2e4aa404130ed296ce55bf6df3c743e018d1a98103895c588c565778268fc08a29a9b3050928d86fabe9e90248e7018300af6a29b284fbb569e2
diff --git a/dev-python/findimports/findimports-2.4.0.ebuild b/dev-python/findimports/findimports-2.4.0.ebuild
new file mode 100644
index 000000000000..a41a1ff447f3
--- /dev/null
+++ b/dev-python/findimports/findimports-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module import analysis tool"
+HOMEPAGE="
+ https://github.com/mgedmin/findimports/
+ https://pypi.org/project/findimports/
+"
+SRC_URI="
+ https://github.com/mgedmin/findimports/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" testsuite.py -v || die
+}