summaryrefslogtreecommitdiff
path: root/dev-python/filetype/filetype-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 09:11:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 09:11:25 +0000
commit06c8293a57349047e228438cc7936e7481ab9159 (patch)
tree6da8926004f93c8934f99c570e0953bd8fb2edf3 /dev-python/filetype/filetype-1.2.0.ebuild
parent670a2ef95331c60f32a0831bfe79445340356b0b (diff)
gentoo auto-resync : 03:11:2022 - 09:11:25
Diffstat (limited to 'dev-python/filetype/filetype-1.2.0.ebuild')
-rw-r--r--dev-python/filetype/filetype-1.2.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/filetype/filetype-1.2.0.ebuild b/dev-python/filetype/filetype-1.2.0.ebuild
new file mode 100644
index 000000000000..deff2d2a388b
--- /dev/null
+++ b/dev-python/filetype/filetype-1.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Small, dependency-free, fast Python package to infer binary file types checking"
+HOMEPAGE="
+ https://github.com/h2non/filetype.py/
+ https://pypi.org/project/filetype/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest