summaryrefslogtreecommitdiff
path: root/dev-python/filelock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/filelock
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/filelock')
-rw-r--r--dev-python/filelock/Manifest4
-rw-r--r--dev-python/filelock/filelock-3.1.0.ebuild22
-rw-r--r--dev-python/filelock/filelock-3.2.0.ebuild25
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 4d2bc4be4d5c..59b7ce0d103a 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1,3 +1,7 @@
DIST py-filelock-3.0.12.tar.gz 587613 BLAKE2B 3eb765e4cb251ace50fcaf3b7cf52939e697d5a710b87eb2f0ea0cf66f554b90bda2e95754b82e1544e45d0abd8dea861f52cdf9c7de0f1e91a8f5c8e0f9759c SHA512 0f30b54b9de2540f023855effcc582b18fedcee6681f21e1733f1b60dbd39eb148e3830bc798a44c5e8c22e7ea8ca26b6d4547fae79dacc78c62b819a3d84683
+DIST py-filelock-3.1.0.tar.gz 584958 BLAKE2B 29ce6c14ece7a45104ceda46bbb261730f7bf3e7df9d20be783a8e8324ca350e8b02a099f4273aff953281e10d305772c3572a72377f1039d0763c3d87173289 SHA512 cffca48f9e7b39a750bcecdbd4a1c8fd2a57c0eddd41fb735930ecb954550620ab89994cc159b6f0ada2cc0961a097e5e2c2ac380de424b59b111a3290682b86
+DIST py-filelock-3.2.0.tar.gz 584871 BLAKE2B 67c5d85dd030007c12f549e772eac8d028c9f0ee9abac4b5106bbcae91e5447e7c6394938877b718630c22323c53ebc28a8bff8b2e323401f027807f7447017b SHA512 8c2f3980090b798ca0103158731a816443bf461a40d79f337e1c102aee50b3885d2b30113d509a8457df20a2cef196e70b2313fbe3f5b44557b817e5a6154d80
EBUILD filelock-3.0.12-r1.ebuild 640 BLAKE2B 798ef67b1ee71b99c065b48a8d5b54f9407a32d742a02a8d86e0c5f978662b2370afdc72617af1ec7712882bba3a92afbece905631265c1491a83f28db8971a3 SHA512 027590809537070c19811c080177863b21233728fa8db3c590763600a695898744e777d2a7f3a6a3cd48b04c2d1e6817e44ff59721ba7d254e05d5b90620d922
+EBUILD filelock-3.1.0.ebuild 682 BLAKE2B 15dcf39ee226422f1c84059de265aa5ce6c7a8904dba2eeee5cd935533dec4075984daacc37724c78010f90b03683f59ac3b40cd4ddf0ef74f1e0d9526a9b3d0 SHA512 c823957d1340e507ec6c29a034f43f4c613e8af0b4a557a6f60df297c18b71db76cc81db9868122a5044b131f97f2e28ca87eddf507e1282702c976040378f21
+EBUILD filelock-3.2.0.ebuild 749 BLAKE2B b74df2eee9c8ba9cdf1b8522be33b9108dd98a02e1614019cce1e762e0c2bc7d9270df5236597c760a7180facfd89cd938a175e6f1f55dc5d031648380c42873 SHA512 5d6344e4da56d1e441a02ef209f252e7d372702e638a942d359c07499550d79071e96fa250256bbac5ad61cbc4acbeb350ef9385642cf9ad74e01e5b2f3803f2
MISC metadata.xml 381 BLAKE2B 2a49a48af3a92fe1cdf2c124d1358793a3a54f77c81b1548e06ea4ecc98a8043570ed24786af5d750bd6146f79d5ea75b477c6465d12f1d4a29754002de5bdc0 SHA512 252752e2bf29b3530576ab1e8de05cebffd1ed36ea7b473cb6e51a99c9763f8caeb9851a432dc4e84ce96fa653ac08d087f7f275c89bd8e66f8b91348856bdef
diff --git a/dev-python/filelock/filelock-3.1.0.ebuild b/dev-python/filelock/filelock-3.1.0.ebuild
new file mode 100644
index 000000000000..ec08c0f21c42
--- /dev/null
+++ b/dev-python/filelock/filelock-3.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="https://github.com/benediktschmitt/py-filelock
+ https://pypi.org/project/filelock/"
+SRC_URI="https://github.com/benediktschmitt/py-filelock/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
diff --git a/dev-python/filelock/filelock-3.2.0.ebuild b/dev-python/filelock/filelock-3.2.0.ebuild
new file mode 100644
index 000000000000..5e3fcb6a7949
--- /dev/null
+++ b/dev-python/filelock/filelock-3.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2018-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="https://github.com/benediktschmitt/py-filelock
+ https://pypi.org/project/filelock/"
+SRC_URI="https://github.com/benediktschmitt/py-filelock/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}