summaryrefslogtreecommitdiff
path: root/dev-python/filelock/filelock-3.13.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-10 12:32:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-10 12:32:09 +0100
commitbcb1bf8297438e33e98fec6991ba68dec0f4dd7c (patch)
tree641656fce8ff13ec9fae86d68bd03073d9afc4a0 /dev-python/filelock/filelock-3.13.4.ebuild
parentfb0d4b003026d01b3d52956c7a0069b9363efff8 (diff)
gentoo auto-resync : 10:04:2024 - 12:32:09
Diffstat (limited to 'dev-python/filelock/filelock-3.13.4.ebuild')
-rw-r--r--dev-python/filelock/filelock-3.13.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/filelock/filelock-3.13.4.ebuild b/dev-python/filelock/filelock-3.13.4.ebuild
new file mode 100644
index 000000000000..48908464f081
--- /dev/null
+++ b/dev-python/filelock/filelock-3.13.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/filelock/
+ https://pypi.org/project/filelock/
+"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest