summaryrefslogtreecommitdiff
path: root/dev-python/filelock/filelock-3.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-07 11:29:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-07 11:29:55 +0100
commita17b25a10359070f9527893d861369d378021aa9 (patch)
tree02188942c1da9eb507b509fbd36c9b7a5aff86c8 /dev-python/filelock/filelock-3.11.0.ebuild
parentefbb52742172c497c5245486906aade0fb6220e8 (diff)
gentoo auto-resync : 07:04:2023 - 11:29:55
Diffstat (limited to 'dev-python/filelock/filelock-3.11.0.ebuild')
-rw-r--r--dev-python/filelock/filelock-3.11.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/filelock/filelock-3.11.0.ebuild b/dev-python/filelock/filelock-3.11.0.ebuild
new file mode 100644
index 000000000000..86d1f81ea020
--- /dev/null
+++ b/dev-python/filelock/filelock-3.11.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/
+"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest