summaryrefslogtreecommitdiff
path: root/dev-python/figleaf/figleaf-0.6.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/figleaf/figleaf-0.6.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/figleaf/figleaf-0.6.1-r1.ebuild')
-rw-r--r--dev-python/figleaf/figleaf-0.6.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/figleaf/figleaf-0.6.1-r1.ebuild b/dev-python/figleaf/figleaf-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..0a9ad08bbc6d
--- /dev/null
+++ b/dev-python/figleaf/figleaf-0.6.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage tool"
+HOMEPAGE="http://darcs.idyll.org/~t/projects/figleaf/doc/ https://pypi.python.org/pypi/figleaf"
+SRC_URI="http://darcs.idyll.org/~t/projects/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS="doc/*.txt doc/ChangeLog"
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}