summaryrefslogtreecommitdiff
path: root/dev-python/fields/fields-5.0.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/fields/fields-5.0.0-r3.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/fields/fields-5.0.0-r3.ebuild')
-rw-r--r--dev-python/fields/fields-5.0.0-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/fields/fields-5.0.0-r3.ebuild b/dev-python/fields/fields-5.0.0-r3.ebuild
new file mode 100644
index 000000000000..e1b2cac8b857
--- /dev/null
+++ b/dev-python/fields/fields-5.0.0-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Container class boilerplate killer"
+HOMEPAGE="
+ https://github.com/ionelmc/python-fields/
+ https://pypi.org/project/fields/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/characteristic[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r \
+ -e "/--benchmark-disable/d" \
+ -e 's|\[pytest\]|\[tool:pytest\]|' \
+ -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest --ignore tests/test_perf.py tests
+}