summaryrefslogtreecommitdiff
path: root/dev-python/fedmsg/fedmsg-0.18.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/fedmsg/fedmsg-0.18.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/fedmsg/fedmsg-0.18.3.ebuild')
-rw-r--r--dev-python/fedmsg/fedmsg-0.18.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/fedmsg/fedmsg-0.18.3.ebuild b/dev-python/fedmsg/fedmsg-0.18.3.ebuild
new file mode 100644
index 000000000000..4713bff3b3e1
--- /dev/null
+++ b/dev-python/fedmsg/fedmsg-0.18.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Fedora Messaging Client API"
+HOMEPAGE="http://www.fedmsg.com/ https://pypi.org/project/fedmsg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/0.18.0-endpoints.patch"
+ "${FILESDIR}/0.18.0-no_signatures.patch" )
+RDEPEND="
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/kitchen[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/m2crypto[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}"
+DOCS=(
+ "README.rst" "CHANGELOG.rst"
+ #TODO: doc/ dir full of rst files
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /etc/
+ doins -r "${S}/fedmsg.d"
+}