summaryrefslogtreecommitdiff
path: root/dev-python/fastjsonschema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-29 07:40:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-29 07:40:48 +0000
commit8d12644534a171c85dd84343b976054ad30faa6d (patch)
tree1bbdbe1f1cc6b952253c203b199150ab19502004 /dev-python/fastjsonschema
parentdd5af718da993c9a6f040afb037ba1246974c6e5 (diff)
gentoo auto-resync : 29:12:2023 - 07:40:48
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest2
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 2b0f308612c9..5705f309e225 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1,3 +1,5 @@
DIST fastjsonschema-2.19.0.tar.gz 371202 BLAKE2B 56103ae94d52a337ceb830b7dfe68b3e1c3d5bdfbe46c8c042b5bc1a6d4e36201176a274135779cbf50a9ce939d95f5bd3c5bd88b7a6483db4cc438bff1d986a SHA512 d26c7f44acfeb4210fad188e3fe5486231a516fb0a4fa7d756dd9d1378b22afd7b4acb6b34085cabcfe31dac44a605de6f90a158a3af69de97f8926d59b3a105
+DIST fastjsonschema-2.19.1.tar.gz 372732 BLAKE2B f028e027483e02969c4d750a888659add9dd7f661776ab42242f74492272267b93a2248cdc50b78389091cc1a1fd7661abbf377d81edf73df35ed1e222be7328 SHA512 b276788ebe1d3a6bc5d1463c2a4940fbe5c9e0a7919c813b78f385faa406527cac34d4042e6a69e0ca1631f3e5ed0bc351e13d9d1e245132a1607e010a5a2346
EBUILD fastjsonschema-2.19.0.ebuild 563 BLAKE2B 132b93c04da9eaa4e9f79435043d737551067d241a78396e2f08d428d568442319990d653fae79caafc93dab41d5579da0a865a8fd9c8199040f0d6fb7e29494 SHA512 d081fe6f4a33c22e708641f86e8c651a257405b48d52fef2664dc6a339b515f7db1639232aa45330161bdf935269f2c793134ae6cefdd8e0db2571d9750098dc
+EBUILD fastjsonschema-2.19.1.ebuild 571 BLAKE2B 86c6218edf87095ed229020476d82c86aaa779be4a013128d3dadf6832dd1e96a9628ada9fdd2e693442d5b2b178cb7976b6ed68bcd99036d28d147d18cf8643 SHA512 4de99c48a1a5c5ac1e238c3ed74dcb72ddef9c53b797f6ba5c4cb7881ee1010dcab516fd11af89e1af6c6e57f31c25142aa26c8cfcb7a35b24d2b1309c7034fe
MISC metadata.xml 390 BLAKE2B d29071ddcb0aea8db343c2924de51e8fdbf9295898c687ca0f474e007007407c9a402cd2fa74f0f2142dfb2f14a2cfd0c51c05f5fad6891734328a003283821f SHA512 db3339aaba0218ebea0ea4cd5b950dbf74572b18341f595fbbbe1f67c0c9c23413f4a98aeec5b49b036533cfea46e8f2a74f5f999c3b4c472a66297346139b05
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild
new file mode 100644
index 000000000000..e1529c815ca6
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)