summaryrefslogtreecommitdiff
path: root/dev-python/fastimport/fastimport-0.9.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/fastimport/fastimport-0.9.14.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/fastimport/fastimport-0.9.14.ebuild')
-rw-r--r--dev-python/fastimport/fastimport-0.9.14.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/fastimport/fastimport-0.9.14.ebuild b/dev-python/fastimport/fastimport-0.9.14.ebuild
new file mode 100644
index 000000000000..f785e8ef6c57
--- /dev/null
+++ b/dev-python/fastimport/fastimport-0.9.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for parsing the fastimport VCS serialization format"
+HOMEPAGE="
+ https://github.com/jelmer/python-fastimport/
+ https://pypi.org/project/fastimport/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v fastimport.tests.test_suite ||
+ die "Tests fail with ${EPYTHON}"
+}