summaryrefslogtreecommitdiff
path: root/dev-python/fakeredis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/fakeredis
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest2
-rw-r--r--dev-python/fakeredis/fakeredis-1.7.1.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 45ff25eca6fd..1936a4378c34 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,3 +1,5 @@
DIST fakeredis-1.7.0.gh.tar.gz 71108 BLAKE2B 64b4c8aa2891ac6afd7789e5a8dce4d1a0ccd6a5083b410fd051d871d4ea9748e9d687eb27bbaeea646747f4bf170089d3ef711d6db0d6a88d8b7e755d165b6d SHA512 a8c67929e63196fea45b85097aaf6bf7402679510e471a8d13bdc0f7320e983107416d3e515fa85b1d6a6217fb82dbda7b4425c3c80ac54a1ac50eee875b0fbd
+DIST fakeredis-1.7.1.gh.tar.gz 71151 BLAKE2B 87877c94a4c03ad6ff4b55f307526f712daa860257374a97a8f7bd29440d171467e18e4041ca56bb6af30df30481a3d5b13c7d0657ba3eb7673a653664ffbe8a SHA512 f41d9393ae50bae9de064678948f4364fc47db06f489782e5b428f449828ad5813b08b2fb053bef878b2a1b500edbb0ea1881449dbd12c2b6e385f6a2fba4c59
EBUILD fakeredis-1.7.0.ebuild 1860 BLAKE2B 4b15c80a0352aeaa36685e3dded9095c05887745163e4ef3bbd6a55ff9b77697f8f738a03c2c13e2c7b4866af7c92fc6f58f890466d20e814dc078023071a750 SHA512 f654f833515b26519c59da0224fac46ddb98cd19b1158de1fc8793b59e61f5f65ba50a579d5274741e66facc9aa03b6d636d379c1a8b35149c0000e4c7938c25
+EBUILD fakeredis-1.7.1.ebuild 1878 BLAKE2B d29c311e22a2605c842b36b32ffd2ed1e78e209c457e108fbf07377e00ffadcc48a0dbda7075f1b56a3531b29e66917a161be3562f42fecea56940e4756da600 SHA512 f492e3ce2ede4e1c94a474d66e1136a8009a5c6a81618eb84ed339dc8b64e6e47d2067e476b40694d79ac63e6e22dfdf40502a9b043ab54369a1e38b4d2d2e9c
MISC metadata.xml 372 BLAKE2B 7d33e3f97f80538c9bdd35bd71a28b9ed81ad338888dc876635c106d89170d3b6f3a7341ed1be79555f8e8479aa84392353480ca85ff215ea3b4b9cea86cdae2 SHA512 19d9187049c5b597005e3769a2c9a8c26c6f96859c97d13121652a7ca367786107480ccc6eebbeb7896e56bbb02e2012694d4119bc5cf6660e6cda325052977f
diff --git a/dev-python/fakeredis/fakeredis-1.7.1.ebuild b/dev-python/fakeredis/fakeredis-1.7.1.ebuild
new file mode 100644
index 000000000000..c77dd1ff9452
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-1.7.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/jamesls/fakeredis/
+ https://pypi.org/project/fakeredis/"
+SRC_URI="
+ https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/redis-py-4.2.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/aioredis[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ test/test_aioredis2.py::test_blocking_unblock
+ test/test_aioredis2.py::test_pubsub
+ "test/test_aioredis2.py::test_repr[fake]"
+ test/test_hypothesis.py::TestJoint::test
+ test/test_hypothesis.py::TestFuzz::test
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ "test/test_aioredis2.py::test_failed_script_error[fake]"
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
+
+pkg_postinst() {
+ optfeature "Mock aioredis" dev-python/aioredis
+}