summaryrefslogtreecommitdiff
path: root/dev-python/eyeD3/eyeD3-0.9.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/eyeD3/eyeD3-0.9.6.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/eyeD3/eyeD3-0.9.6.ebuild')
-rw-r--r--dev-python/eyeD3/eyeD3-0.9.6.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/eyeD3/eyeD3-0.9.6.ebuild b/dev-python/eyeD3/eyeD3-0.9.6.ebuild
deleted file mode 100644
index 8245a9dc9755..000000000000
--- a/dev-python/eyeD3/eyeD3-0.9.6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Module for manipulating ID3 (v1 + v2) tags in Python"
-HOMEPAGE="https://eyed3.nicfit.net/"
-SRC_URI="https://github.com/nicfit/eyeD3/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://eyed3.nicfit.net/releases/eyeD3-test-data.tgz )"
-
-LICENSE="GPL-2"
-SLOT="0.7"
-KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/deprecation[${PYTHON_USEDEP}]
- dev-python/filetype[${PYTHON_USEDEP}]"
-# note: most of the deps are optional runtime deps / plugin deps
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pylast[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # requires unpackaged factory-boy, doesn't seem to relevant
- # to anything but eyeD3 usage with factory-boy
- rm tests/test_factory.py || die
- # requires unpackaged grako
- rm tests/test_display_plugin.py || die
-
- if use test; then
- mv "${WORKDIR}"/eyeD3-test-data tests/data || die
- fi
-
- distutils-r1_src_prepare
-}