summaryrefslogtreecommitdiff
path: root/dev-python/expandvars
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
commit51a01b0f2371b8dfc39f2747ecafd7d5f083ecb4 (patch)
tree55d5c62353eb98ea2809ea087e9fc4b215c53563 /dev-python/expandvars
parent46de1a2f454a1465026d681f5dfe8db7dde5b126 (diff)
gentoo auto-resync : 21:11:2023 - 23:10:38
Diffstat (limited to 'dev-python/expandvars')
-rw-r--r--dev-python/expandvars/Manifest3
-rw-r--r--dev-python/expandvars/expandvars-0.11.0.ebuild41
-rw-r--r--dev-python/expandvars/metadata.xml12
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/expandvars/Manifest b/dev-python/expandvars/Manifest
new file mode 100644
index 000000000000..74a65b8cda3d
--- /dev/null
+++ b/dev-python/expandvars/Manifest
@@ -0,0 +1,3 @@
+DIST expandvars-0.11.0.gh.tar.gz 10663 BLAKE2B cfbcb8bedc61cc8b1e88d4774784518e15846f7ea5ddbf58bd016ea2043dd5b1c9e55af117f6482e05e9ae4ba07e01d0fb471a72719f38191f1a29a9f66387a9 SHA512 e8de6544f2d369728e35c8b862662f348f46673f836f8b14dbdcfdc3dbcb7efda80deb55f8bcd597037ac974752e2463d429ddda3b8502fe19c402c253babf7f
+EBUILD expandvars-0.11.0.ebuild 813 BLAKE2B e5e0b5a2f0cc2c436453fb57b522f3b8ad9534ecb0f42fce0274481d387013cb866177012bc20ee8fd41352b19fb9d264ef31afc7a0d07520d032d1d54ad671a SHA512 b6f09f1530404a7f3ace2797e1e7f07962fe025f7be443cee1c740ee26c65b201b119e4912bde66113e5d215a06a55a4f581e9459334b740d20c31727271be4d
+MISC metadata.xml 378 BLAKE2B ea984772fa8cd80ee947c6a950e90357d88fee179f2c389ac904b73aaeff153537f662f3f21604772c341e89b6d8ad772cf0e2ac253cd0a2a0038ab93d056dd4 SHA512 6fc7c7d666e6dc0d342525d9cef241a8cbd3f3f3725570dd3819628e1967c6a9a536a6df93266a55cafafd2e5cf0b1588fdc2fc1c9238919fb155f7b833cb212
diff --git a/dev-python/expandvars/expandvars-0.11.0.ebuild b/dev-python/expandvars/expandvars-0.11.0.ebuild
new file mode 100644
index 000000000000..fff34e6d3299
--- /dev/null
+++ b/dev-python/expandvars/expandvars-0.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Expand system variables Unix style"
+HOMEPAGE="
+ https://github.com/sayanarijit/expandvars/
+ https://pypi.org/project/expandvars/
+"
+SRC_URI="
+ https://github.com/sayanarijit/expandvars/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires toml, useless
+ tests/test_expandvars.py::test_version
+)
+
+src_prepare() {
+ # sigh
+ cat >> pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["poetry-core"]
+ build-backend = "poetry.core.masonry.api"
+ EOF
+
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/expandvars/metadata.xml b/dev-python/expandvars/metadata.xml
new file mode 100644
index 000000000000..d66a900919de
--- /dev/null
+++ b/dev-python/expandvars/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">sayanarijit/expandvars</remote-id>
+ <remote-id type="pypi">expandvars</remote-id>
+ </upstream>
+</pkgmetadata>