summaryrefslogtreecommitdiff
path: root/dev-python/executing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
commit896d6a8a88861c42b5d531a2f147c8a29a149bd8 (patch)
tree081fe10813721a96088dca6b54bc35bcac18afc6 /dev-python/executing
parent3059f20995d5ac642b7b4a38d538fdf1cc45d90d (diff)
gentoo auto-resync : 01:12:2022 - 20:53:45
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest4
-rw-r--r--dev-python/executing/executing-1.1.1.ebuild46
-rw-r--r--dev-python/executing/executing-1.2.0.ebuild2
3 files changed, 2 insertions, 50 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 89e87b8b27e6..5864a5ed94f2 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,5 +1,3 @@
-DIST executing-1.1.1.gh.tar.gz 661228 BLAKE2B 66ba8509a82d7c7354d70747d08e160423314718a2c1844260104eff474d39a244f880984e2388997f5620905a2f3fd90fcfa393f48e98cd5990e01a053012d6 SHA512 2b2277aa68d1abf2f1bbbf9010f7a27652f74e892e564a3c6269ea1110208b4c2fbf6a002b90423f5e9aa718cf698f996d21930b431241cf88012f20d244eeae
DIST executing-1.2.0.gh.tar.gz 663650 BLAKE2B ba9420bfcf3805223e6b7e84d65499f3a73ef3156480586d2c5ffde4e438fcf8474f4f02c123953d04ee253de7a6a3a1b2587e57fcae546f3dae7af70a1aaa98 SHA512 c841958cc499b2d78c94570bf0556933d4a58ca5541f7a59e591be6036926ab79d5ae86bb95bbf649f3c3fb729109fe50cf04fbc72692e0cfe12edaa995ea0a6
-EBUILD executing-1.1.1.ebuild 1085 BLAKE2B f44483dedbc51b09fc3c2c4c3740fd255d193b711d4b8f6d145589b31a6bebdcdebe70aa8a27768d109aa1880fd9e4718dded7d6f8fd2359e880b1af151f4619 SHA512 8ebd0d125f98722b246664c0f9555b746d06926ed6d6ad378f3cf3f59e0aa8bf8e8cf3c9cb5eb33b1585b56100d69cfafbdea16e790d13832a40c9b7f84240fa
-EBUILD executing-1.2.0.ebuild 1089 BLAKE2B 34f8dde003b9ef6212283c3f539518d64ce5e982360509d477a701f85921170e7a09b43cda586a286ad7b074efb353da7329a893f06764bd17a28d6a5aa67e40 SHA512 2fe1501939965031e50cb63c01d3e9a898dc0225772950f752df9f1744fa2cf9e856e3e7991ca1424cbd3ce797e174ad10962cdbfe1b32d0dba7dbc295ffe9af
+EBUILD executing-1.2.0.ebuild 1085 BLAKE2B f44483dedbc51b09fc3c2c4c3740fd255d193b711d4b8f6d145589b31a6bebdcdebe70aa8a27768d109aa1880fd9e4718dded7d6f8fd2359e880b1af151f4619 SHA512 8ebd0d125f98722b246664c0f9555b746d06926ed6d6ad378f3cf3f59e0aa8bf8e8cf3c9cb5eb33b1585b56100d69cfafbdea16e790d13832a40c9b7f84240fa
MISC metadata.xml 351 BLAKE2B 3e64042e3da09377bd27bcf09b9984eef77bbbc18e84f1e849571ff628cd15068fa680560cfc6c3650bf545e5869c6e3d6be0b4d2fc00f35c5fc58dcc3194eb1 SHA512 de199443767adf299da6c7d857c182071746b2ccf7b84015e9649675451ff336fdb7ac1df2d15951ae708ddf0529f2f1c9c19a2959f45c0dc30db1f341fb8d0f
diff --git a/dev-python/executing/executing-1.1.1.ebuild b/dev-python/executing/executing-1.1.1.ebuild
deleted file mode 100644
index c30d19f28ed4..000000000000
--- a/dev-python/executing/executing-1.1.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Get information about what a Python frame is currently doing"
-HOMEPAGE="
- https://github.com/alexmojaki/executing/
- https://pypi.org/project/executing/
-"
-SRC_URI="
- https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- dev-python/littleutils[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- # this test explodes when collected by pytest
- "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
- epytest tests/test_pytest.py
-}
-
-pkg_postinst() {
- optfeature "getting node's source code" dev-python/asttokens
-}
diff --git a/dev-python/executing/executing-1.2.0.ebuild b/dev-python/executing/executing-1.2.0.ebuild
index 507fb1b0cdcf..c30d19f28ed4 100644
--- a/dev-python/executing/executing-1.2.0.ebuild
+++ b/dev-python/executing/executing-1.2.0.ebuild
@@ -20,7 +20,7 @@ SRC_URI="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~hppa ~ia64 ~ppc ppc64 ~riscv ~s390 ~sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]