summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-28 09:59:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-28 09:59:10 +0100
commit8eb973cc2247ee4fe34e4d907fdc6cf5b94709e3 (patch)
tree0834df6dbfa798c2c138698cc26cf6a731fe937e /dev-python/exceptiongroup
parente5985b8e66b3b43c34328efb47b9b12e8ce5a690 (diff)
gentoo auto-resync : 28:10:2022 - 09:59:10
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest2
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.0.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index badcdaabe1e9..ec0d2bdb4189 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,5 +1,7 @@
+DIST exceptiongroup-1.0.0.gh.tar.gz 19766 BLAKE2B 2c4aa2c7c096b91971872b2236fad211a1bd7cb8ae921f5a0255b5a534eefdb5033bbca4c562ff7045acf30e13371a38d52851749cd5bca4df6adfe359a43012 SHA512 e2e05066c0c7664bb36696737c0c33abd811637c5f0ae7e70a20525283d4db4667fa814b15cb6b21165416ae1a0c47f22250a2ed9be4be99b6237e0c1b45fdd4
DIST exceptiongroup-1.0.0rc8.gh.tar.gz 17562 BLAKE2B 617e174e32f4c062f576b12c9dfe96e5495003097dc0da82e383019a65b2a043546d4b73181081defb641d453127e056be52e55e76fdf0ec0247513f5eb211ff SHA512 f7f1700403f345755a1e32c77eb43744b366b1f55446e1898dd960988d23396ad8334bef072ecc7ec5ac7075300f0f3e8e9a0d454d9dd80677ae55b4166fc6e4
DIST exceptiongroup-1.0.0rc9.gh.tar.gz 19109 BLAKE2B b4a4c127909908aa2d9fb2bfff0f0ae6c6b9be88046a680b6b206164b0ec0d6bc325ec65ce3e61df2270e6b0397ff5f7f11c219a62dc4a3534b1564da64935b3 SHA512 43f0f7338f5e09d45a5b4e1723ecab6dcd1872a387eaf8483961b86db5f1b7c265798538726ec9f2d0d6bd289ff3124883f5095dd7f04fd9b64c9230ce454098
+EBUILD exceptiongroup-1.0.0.ebuild 770 BLAKE2B b0bd0b8fb1edb61e570eac329219319ead6fb6273aaab2e828446f56d6534a8753fefdbd059ffab172a746d1f60ceaf7fbc281ea466af11d37f9bda8da38e598 SHA512 ddbf7e5089ad4d90183f949b1bf9122a4f86189dd98a3e53fc0d515bf1f261e7c64c71a6ef94b11a833ea63b228b3725e4f38050ce44be26f1363a0fd8023554
EBUILD exceptiongroup-1.0.0_rc8.ebuild 762 BLAKE2B d9157df63bd73187f1abe6b2b9bc81d1920177ddcc039d06cd8f42e5a3904b9fedb695f047aafe2468b0dce6448d6db3ffb1d7856bd149f1136782a3b0333c5f SHA512 fb93d9f4e6fdbc4f7363b53777d005378d5f9cf088acb72b7cd532aaf38420c1892d4a228c9a8575f1e389c52dabdef40a3d22a382bfd738ce9b0fbc6558b20f
EBUILD exceptiongroup-1.0.0_rc9.ebuild 770 BLAKE2B b0bd0b8fb1edb61e570eac329219319ead6fb6273aaab2e828446f56d6534a8753fefdbd059ffab172a746d1f60ceaf7fbc281ea466af11d37f9bda8da38e598 SHA512 ddbf7e5089ad4d90183f949b1bf9122a4f86189dd98a3e53fc0d515bf1f261e7c64c71a6ef94b11a833ea63b228b3725e4f38050ce44be26f1363a0fd8023554
MISC metadata.xml 360 BLAKE2B accdc2d9dc39a31238555b937189f135482f2094a570396a741ba6202a1243ad46c99003e829e59e4e5fd0db0a01b050cc0e385bf28b44892e3e3c5615351028 SHA512 d740125cf760309a4dc5de1981b5ad704e880c37588e8a0e17816709065d80ad2ffecb3b5e50725b5665a38594a53f9659c17b35eb34bffbb06d11b830d740cd
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.0.0.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.0.0.ebuild
new file mode 100644
index 000000000000..b848cb3eea31
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}