summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
commit51a01b0f2371b8dfc39f2747ecafd7d5f083ecb4 (patch)
tree55d5c62353eb98ea2809ea087e9fc4b215c53563 /dev-python/exceptiongroup
parent46de1a2f454a1465026d681f5dfe8db7dde5b126 (diff)
gentoo auto-resync : 21:11:2023 - 23:10:38
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest2
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.2.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index 4af92441c90f..f2bb8fdb2174 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,3 +1,5 @@
DIST exceptiongroup-1.1.3.gh.tar.gz 24057 BLAKE2B c178152b92ac4079bb10614918d80f1b772f1d2c02e82fdbc19fc576c434df5f92d731116b46145ef3c3a3e57b4b899f6be11e2452a13170d27072b6b2ad74b5 SHA512 fddc52abb6b61c024c5832f6d2ed723a834c31e2bc713a3c5796581e8edbd3299d9342885cfcb5ed83ad7f7fdbb7c461ffcec354c0328a740a40d5340997d1c8
+DIST exceptiongroup-1.2.0.gh.tar.gz 27368 BLAKE2B 93ac3872fe9f9f0eab80b9e667308a8f1d06541dbfa19dda5bcbd7d9c7d6963872294b7549d88a10e0574e9db1aaa7bd39748e1237ac86e1f83dbb2ef89686d0 SHA512 eeac523fd338099dea66c5b2f7fcc070612746487be244deba8a1c731c1f23db24763dd9e35c28dfb9460b49c645f380e6858f998f95b9244dfb82f5549f159b
EBUILD exceptiongroup-1.1.3.ebuild 877 BLAKE2B f361f7aa1ded845031c2631788a79cc7996e24c5fb29ba079d2b5036545a57f763a0b82399fbd44a27d749f406810f20c9131ab15ef1d901c2505c56c5c5ccd8 SHA512 f0c4b8b675fdcfd619d792d9a9a93ce67251cffd4064b5ceb634fd58d80751eceabd1ae77ed54327e4291e6fe559331365aebb96cc2b6c607529eb7174a15bad
+EBUILD exceptiongroup-1.2.0.ebuild 885 BLAKE2B 2f05453c05dc11ae7b24b152bb35f100d2bafc2c68a8e00a8cf4e422c66b79e9de6dd41fc84b9122da508546ce5ca8a9fef37c897b18c997b0d419e168ea07b7 SHA512 3a29895fb3382a5cd844a633baa0f963b14a5f2cd62936e1678cb4d27dd16be2eae8eabafaa92445920c2e42be5ad905c13f08ee92aaced874b32fc7dadf9408
MISC metadata.xml 384 BLAKE2B 248abcb5fc08c91396cdbff52e5c3e4f6cce2aa273cfd52b48ee13de9ccdaecd09e9a436ed79f258d15d8d4583fe5995e054010c909a522f47e6866e55b3458f SHA512 c631c69438059cb2a6c80e595e45fac904d32dfb53f8be183142f1195d3a3b9bc14bc240f0808e14f47d31beb1887ad82ee79c5f1847c8e6b59dbfeea7913c8b
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.2.0.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.2.0.ebuild
new file mode 100644
index 000000000000..df9172779f44
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+# pypi sdist does not include tests as of 1.1.1
+# https://github.com/agronholm/exceptiongroup/pull/59
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}