summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup/exceptiongroup-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 11:03:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 11:03:04 +0100
commit0968caae52d6eae7513e2ce4e0900a2e009780ee (patch)
tree54218d0d3baaf14b964427f98c4f90f13380ffd3 /dev-python/exceptiongroup/exceptiongroup-1.1.2.ebuild
parent58018a2c9504435bb719f2d60439ebe22fbeb503 (diff)
gentoo auto-resync : 17:09:2023 - 11:03:03
Diffstat (limited to 'dev-python/exceptiongroup/exceptiongroup-1.1.2.ebuild')
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.1.2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.1.2.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.1.2.ebuild
deleted file mode 100644
index c06238b9a508..000000000000
--- a/dev-python/exceptiongroup/exceptiongroup-1.1.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit_scm
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=${P/_}
-DESCRIPTION="Backport of PEP 654 (exception groups)"
-HOMEPAGE="
- https://github.com/agronholm/exceptiongroup/
- https://pypi.org/project/exceptiongroup/
-"
-# pypi sdist does not include tests as of 1.1.1
-# https://github.com/agronholm/exceptiongroup/pull/59
-SRC_URI="
- https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT PSF-2.4"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}