summaryrefslogtreecommitdiff
path: root/dev-python/ewmh/ewmh-0.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/ewmh/ewmh-0.1.6.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/ewmh/ewmh-0.1.6.ebuild')
-rw-r--r--dev-python/ewmh/ewmh-0.1.6.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/ewmh/ewmh-0.1.6.ebuild b/dev-python/ewmh/ewmh-0.1.6.ebuild
new file mode 100644
index 000000000000..41e1c834122e
--- /dev/null
+++ b/dev-python/ewmh/ewmh-0.1.6.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of Extended Window Manager Hints, based on Xlib"
+HOMEPAGE="https://github.com/parkouss/pyewmh https://pypi.python.org/pypi/ewmh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/python-xlib[${PYTHON_USEDEP}]"