summaryrefslogtreecommitdiff
path: root/dev-python/eradicate/eradicate-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-09 15:48:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-09 15:48:37 +0100
commit60010a4cd6d7c12aaa62f00b5e8a158ed24efba6 (patch)
treea961dd82d2d2719fe5bede9343e9e83cce856d9f /dev-python/eradicate/eradicate-2.3.0.ebuild
parent65a4d80ebaba5d4d407b3d09320b337e0ca20f0a (diff)
gentoo auto-resync : 09:06:2023 - 15:48:36
Diffstat (limited to 'dev-python/eradicate/eradicate-2.3.0.ebuild')
-rw-r--r--dev-python/eradicate/eradicate-2.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/eradicate/eradicate-2.3.0.ebuild b/dev-python/eradicate/eradicate-2.3.0.ebuild
new file mode 100644
index 000000000000..0ee0a07f33fc
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="
+ https://github.com/wemake-services/eradicate/
+ https://pypi.org/project/eradicate/
+"
+SRC_URI="
+ https://github.com/wemake-services/eradicate/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest