summaryrefslogtreecommitdiff
path: root/dev-python/eradicate/eradicate-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/eradicate/eradicate-2.1.0.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/eradicate/eradicate-2.1.0.ebuild')
-rw-r--r--dev-python/eradicate/eradicate-2.1.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/eradicate/eradicate-2.1.0.ebuild b/dev-python/eradicate/eradicate-2.1.0.ebuild
new file mode 100644
index 000000000000..3d56e702338b
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="https://github.com/myint/eradicate"
+# TODO: revert to PyPI tarball once it includes tests
+# https://github.com/myint/eradicate/pull/28
+SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest