summaryrefslogtreecommitdiff
path: root/dev-python/enzyme/enzyme-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/enzyme/enzyme-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/enzyme/enzyme-9999.ebuild')
-rw-r--r--dev-python/enzyme/enzyme-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/enzyme/enzyme-9999.ebuild b/dev-python/enzyme/enzyme-9999.ebuild
new file mode 100644
index 000000000000..7f2df624691c
--- /dev/null
+++ b/dev-python/enzyme/enzyme-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE='xml(+)'
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python video metadata parser"
+HOMEPAGE="https://github.com/Diaoul/enzyme https://pypi.org/project/enzyme/"
+EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
+SRC_URI="test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ app-arch/unzip
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+src_unpack() {
+ default_src_unpack
+ git-r3_src_unpack
+}
+
+python_prepare_all() {
+ if use test; then
+ mkdir enzyme/tests/test_{mkv,parsers} || die
+ ln -s "${WORKDIR}"/test*.mkv enzyme/tests/test_mkv/ || die
+ ln -s "${WORKDIR}"/test*.mkv enzyme/tests/test_parsers/ || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}