summaryrefslogtreecommitdiff
path: root/dev-python/enzyme/enzyme-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/enzyme/enzyme-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/enzyme/enzyme-9999.ebuild')
-rw-r--r--dev-python/enzyme/enzyme-9999.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/dev-python/enzyme/enzyme-9999.ebuild b/dev-python/enzyme/enzyme-9999.ebuild
index 303680658ee3..40184beaebb1 100644
--- a/dev-python/enzyme/enzyme-9999.ebuild
+++ b/dev-python/enzyme/enzyme-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
PYTHON_REQ_USE='xml(+)'
inherit distutils-r1 git-r3
@@ -15,12 +15,10 @@ SRC_URI="test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
app-arch/unzip
dev-python/pyyaml[${PYTHON_USEDEP}]
@@ -28,6 +26,8 @@ DEPEND="${RDEPEND}
)
"
+distutils_enable_tests setup.py
+
src_unpack() {
default_src_unpack
git-r3_src_unpack
@@ -42,7 +42,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- esetup.py test
-}