summaryrefslogtreecommitdiff
path: root/dev-python/enzyme/enzyme-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/enzyme/enzyme-9999.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/enzyme/enzyme-9999.ebuild')
-rw-r--r--dev-python/enzyme/enzyme-9999.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/enzyme/enzyme-9999.ebuild b/dev-python/enzyme/enzyme-9999.ebuild
deleted file mode 100644
index 7f2df624691c..000000000000
--- a/dev-python/enzyme/enzyme-9999.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_REQ_USE='xml(+)'
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Python video metadata parser"
-HOMEPAGE="https://github.com/Diaoul/enzyme https://pypi.org/project/enzyme/"
-EGIT_REPO_URI="https://github.com/Diaoul/${PN}.git"
-SRC_URI="test? ( mirror://sourceforge/matroska/test_files/matroska_test_w1_1.zip )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS=""
-IUSE="test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- app-arch/unzip
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-src_unpack() {
- default_src_unpack
- git-r3_src_unpack
-}
-
-python_prepare_all() {
- if use test; then
- mkdir enzyme/tests/test_{mkv,parsers} || die
- ln -s "${WORKDIR}"/test*.mkv enzyme/tests/test_mkv/ || die
- ln -s "${WORKDIR}"/test*.mkv enzyme/tests/test_parsers/ || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}