summaryrefslogtreecommitdiff
path: root/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
commita625efe29cec7f7c437cf33a956ea99eed1e4bd9 (patch)
tree3132969a9e093b34d3bd91ee6110a1111a965630 /dev-python/ensurepip-setuptools/ensurepip-setuptools-69.1.1.ebuild
parent1ff514162358897632ab329134c6bc75af618f10 (diff)
gentoo auto-resync : 24:02:2024 - 11:40:42
Diffstat (limited to 'dev-python/ensurepip-setuptools/ensurepip-setuptools-69.1.1.ebuild')
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-69.1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.1.1.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.1.1.ebuild
new file mode 100644
index 000000000000..97aca4a61872
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-69.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pypi
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${A}"
+}