summaryrefslogtreecommitdiff
path: root/dev-python/enrich/enrich-1.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/enrich/enrich-1.2.6.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/enrich/enrich-1.2.6.ebuild')
-rw-r--r--dev-python/enrich/enrich-1.2.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/enrich/enrich-1.2.6.ebuild b/dev-python/enrich/enrich-1.2.6.ebuild
new file mode 100644
index 000000000000..57f3ea8d5536
--- /dev/null
+++ b/dev-python/enrich/enrich-1.2.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Extend rich functionality"
+HOMEPAGE="https://github.com/pycontribs/enrich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/rich[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest