summaryrefslogtreecommitdiff
path: root/dev-python/emoji/emoji-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-29 07:39:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-29 07:39:57 +0100
commit05f2a11918a15ef57166e74d69d6c4737673e75c (patch)
tree4602fddf74d4aa9ce89809fdbf49adcb5ca527ee /dev-python/emoji/emoji-2.6.0.ebuild
parentbdac6b4aec4024fb844f76b91f3b007b86415e68 (diff)
gentoo auto-resync : 29:06:2023 - 07:39:57
Diffstat (limited to 'dev-python/emoji/emoji-2.6.0.ebuild')
-rw-r--r--dev-python/emoji/emoji-2.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/emoji/emoji-2.6.0.ebuild b/dev-python/emoji/emoji-2.6.0.ebuild
new file mode 100644
index 000000000000..9cf0bc5fde70
--- /dev/null
+++ b/dev-python/emoji/emoji-2.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Emoji for Python"
+HOMEPAGE="
+ https://github.com/carpedm20/emoji/
+ https://pypi.org/project/emoji/
+"
+SRC_URI="
+ https://github.com/carpedm20/emoji/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+distutils_enable_tests pytest